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508 Compliance Guidance for Submission to 
NOAA/CoRIS 
All products and website resources submitted to CoRIS must comply with the Disabilities Act, commonly 
known as Section 508. The content below is a step-by-step guide for making Word and PDF documents 
meet these 508 requirements. These steps should be included in the team’s planning and workflow, as 
those who create/submit the documents are responsible for 508 compliance as much as possible.  

Please contact CoRIS at coris@noaa.gov if you have any questions or need additional assistance. We are 
happy to help! 

Note on Document Format 
Documents posted to CoRIS will ultimately be in PDF format, however to edit a PDF directly for 
compliance you need access to Adobe Acrobat Pro DC software. We realize that not everyone will have 
access to this software, therefore this guide will include both how to make a document as compliant as 
possible in Word as well as instructions on how to edit a PDF.  
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Things to Know Before You Start Your Document 

Top Problem Areas (avoid these if you can) 
• Overly complicated tables (merged or split cells, multiple header rows, sub header cells)
• Graphs or graphics that require color to be understood
• Poor image contrast
• Screengrabs or pictures of text, and scanned images

Things You Will Have to Do (consider these before you start) 
• Make sure all levels of headers are properly identified
• Provide descriptions, or alt tags, of each picture, table, or graphic
• Minimize complex tables
• Review images for contrast issues (make sure they look OK in black and white). The WebAIM

color contrast tool also determines if colors have appropriate contrast
• Make sure all graphs do not require color to be understood
• Format Document Properties and Language
• Run a basic 508 scan

The Process 
• Complete the “Things You Will Have to Do” above
• Send to CoRIS (coris@noaa.gov) for the final 508 review. The team will do a final check of the

document, and notify you if there are extensive issues or fix any minimal issues
• Once the document is finalized, it will be uploaded to the CoRIS catalog

https://webaim.org/resources/contrastchecker/
https://webaim.org/resources/contrastchecker/
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Minimum NOAA Library Standards – The Big 5 

The minimum NOAA requirements for 508 compliance in regards to PDF documents are:  

1. Tagged content: The PDF is a tagged PDF.  Auto-tagging is acceptable. If this step is not done, 
no other elements will pass since they rely on tagging elements. (Adobe tagging information) 

2. Bookmarks: Bookmarks are present on documents over 20 pages and illustrate the structure 
of the document.  If a Table of Contents is present, bookmarks should reflect this (usually just 
headings).   

3. Alternative Text: Alt text is present for all figures, charts, maps, etc. (Adobe alt text info) 
4. Logical reading order: The reading order of the elements is logical and follows the flow of the 

document. (Adobe reading order tool) 
5. Document properties: Title and Language are present.  (Adobe resources about creating and 

editing document metadata) 

You can meet these standards when creating a document in Word as well! Instructions on how to do 
this in Word and Adobe are below. 

 

The Details: Microsoft Word Documents 

Step 1: Apply Heading Levels 
The following heading levels should be present in a document:  

Title, Subtitle (optional), Heading 1, Heading 2 (optional), Heading 3 (optional), and Normal.  

To check these go to “Styles” in the Home Ribbon: 

 

When you click on a heading within the document, a heading level will be highlighted in the ribbon. 
Headings serve as bookmarks and are used to create a table of contents (see the References tab). 

To add or correct headers, select the appropriate text and then the desired heading level within the 
ribbon—or right-click on the appropriate level and select “Update Heading Level to Match Selection” if 
you wish to retain the formatting you created. Repeat as needed for all levels.  

Once added, headings will also appear in the Navigation pane on the left of the page. 

 

 

 

https://libguides.library.noaa.gov/Section508/QuickStart
https://www.adobe.com/accessibility/products/acrobat/pdf-repair-add-tags.html
https://www.adobe.com/accessibility/products/acrobat/pdf-repair-add-alternative-text.html
https://helpx.adobe.com/acrobat/using/touch-reading-order-tool-pdfs.html
https://helpx.adobe.com/acrobat/using/pdf-properties-metadata.html
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Step 2: Add Alternative (“Alt”) Text 
To add alternative text to images/figures/logos in Word:  

1. Right click on the image, and select Format Picture 
2. Choose Layout & Properties in the Format Picture window 
3. Click the arrow next to Alt Text, then add a description in the box 

To add alternative text to tables: 

1. Right click on the table, and select Table Properties 
2. When the Table Properties window pops up, select the Alt Text tab 
3. Add description in the box 

 

 

 

 

 

 

 

 

 

 

 

 

What to include in Alt Text: 

If the figure caption text thoroughly describes what the image is showing, you do not need to repeat it 
as thoroughly in the alt text. If it doesn’t, you need to be descriptive.   

In the alternative text for charts and graphs, give the purpose and function of the chart/graph within the 
context of the surrounding information. Be sure to: 

• Mention any major trends or data points that are highlighted 
• Provide any information that is essential to understanding the image (e.g. colors) 

 
These can be done either in alternative text, or in a longer description outside of the alternative text 
(e.g. figure caption or results text). If a longer description is present in the report text, mention where to 
find it in the alt text. 
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You do not need to describe every dip or rise in a graph, but make sure the overall message displayed by 
the data is conveyed. 

 

Step 3: Setting Document Properties and Language 
To set Document Properties: 

• Select File > Info > Properties > Advanced Properties 
• In the Advanced Properties window, select the Summary tab, and enter in Title and Author. 

Enter in other information fields as needed or appropriate (Category, Keywords, etc.)  

 

 

 

 

 

 

 

 

 

 

 

To set Language: 

• On the Review tab, in the Language Group, select Language, then Set Proofing Language 
• Choose appropriate language 

If there are certain sections of text in another language than the rest of the document, highlight those 
passages and repeat the previous steps. This will set the language for that specific text. 
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Step 4: Not Required but Strongly Encouraged 
The following things are not technically required, but are strongly encouraged as they make it much 
easier for screen readers to parse through the document. 

Table Header Row – formatting the appropriate row to be the “header” of a table. To do this: 

1. Select/highlight the cells of the header row in the table (usually the top/first row) 
2. Select Table Properties 
3. Check box next to “Repeat as header row on the top of each page” 

List formatting – use the provided bulleted, numbered, and multi-level list formatting provided by Word 
when creating lists in your document. 

 

Step 5: Run a 508 Scan  
• Select File > Info > Check for Issues. 
• Then select Check Accessibility. 

 

This will run a basic scan. The results will show up in a list in the “Accessibility Checker” window 
to the right of your document. For the purpose of this guide, we will only focus on missing 
alternate text. (Results such as “Objects not Inline” and “Repeated Blank Characters” are not 
major issues). 
 

 

 
 

 
• From the results, select an image with missing alternate text from the list. 
• Add the appropriate alt text to the image. 
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• Repeat for all images listed without alternative text 
 
Other issues that may come up in the check’s results which should be remediated are: 

• Unstructured document 
• Skipped heading level 
• No header row specified 

 

Step 6: Convert to PDF 
When converting a Word document to a PDF, DO NOT use the "Save as Adobe PDF" option, as 
sometimes the accessibility work you did isn’t carried over. Rather click “File”, "Save As", and then 
change the document type to PDF in the drop down menu. 

 

A way to further ensure all of your 508 work is carried over to the PDF document is to click “Options” 
under the dropdown menu. When the Options window pops up, check the boxes for: Create bookmarks 
using: Headers, Document structure tags for accessibility, and ISO19005-1 compliant (PDF/A). 
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Step 6: Submit Document to CoRIS 
Submit your document to coris@noaa.gov. If applicable, please include your CRCP Project Number and 
Name, or Grant Award Number.  
 
We will then perform a final 508 check, and contact you if we have any questions or if there are 
extensive issues with the document.  
 
After all issues are resolved, we will post it to the CoRIS website https://www.coris.noaa.gov/.  
  
 
 

The Details: PDF Documents 

Step 1: Complete Document Properties  
• Use Adobe Acrobat Pro DC to perform these steps. 
• Select File > Properties, which will open the Document Properties box. 
• In the Description tab, fill in Title and Author. Subject and Keywords (separated by a comma) 

are encouraged but not necessary.  
• In the Initial View tab, choose Document Title from the Show drop-down list. 
• In the Advanced tab, select the appropriate language from the Language drop-down list. 
• Select OK to close the window. 

 

 
 

Step 2: Run Accessibility Checker 
• From the PDF Tools menu, select the Accessibility option then Accessibility Check. 
• Make sure all of the Checking Options in the Accessibility Checker Options dialog are selected, 

and click Start Checking. 
 

mailto:coris@noaa.gov
https://www.coris.noaa.gov/
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• The results appear in a list to the left of the document. 
 

 
 

Step 3: Fix Issues 
While it is only required to fix the NOAA Big 5 requirements listed on page 3 of this document, it is 
encouraged to fix as many issues as possible (especially Table Headers and Tab Order).  
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To fix many of these options you can right click on the issue and select Fix, and a subsequent window 
will pop up where you can fix the error. Other issues are more complicated and trickier to fix. To learn 
more you can right click on the issue, and select Explain. Again, you are not required to fix more difficult 
issues.  

To learn more about Adobe’s Accessibility Checker, what issues mean, and how to fix them, you can look 
at Adobe’s Create and verify PDF accessibility page.  

 

Example of Fixing Alternative Text: 

• To add alternate text, expand the “Figures alternate text – Failed” menu.  
• Right-click on the Figure 1 entry and choose Fix.  

 

 
 

• The Set Alternate Text box will open and provide a space to add alternate text (if it is not already 
fixed). In the case of images, provide descriptions of up to 150 characters. If other elements are 
recognized as images by Adobe Acrobat, such as lines, simply click the Decorative figure box. 
You may click the arrow to navigate to each image requiring alternate text. Be sure to Save & 
Close the box once you are done.  

 

 
 

https://helpx.adobe.com/acrobat/using/create-verify-pdf-accessibility.html
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Step 4: Submit Document to CoRIS 
When all of the required standards are met, submit your document to coris@noaa.gov. If applicable, 
please include your CRCP Project Number and Name, or Grant Award Number. 
 
We will then perform a final 508 check, and contact you if we have any questions or if there are 
extensive issues with the document.  
 
After all issues are resolved, we will post it to the CoRIS website https://www.coris.noaa.gov/. 

 

 

Other Resources 

NOAA Library  
• Collections of webinars and slides with helpful instructions regarding 508 compliance  
• Instructions on how to test for accessibility of Word documents, PDFs, and web pages, as well as 

suggested Screen Reader software 
 

Section508 Government Page 
• Tutorials and guidance on how to create a variety of compliant documents  

 

Adobe Acrobat 
• Acrobat User Guide – Accessibility, Tags, and Reflow 
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mailto:coris@noaa.gov
https://www.coris.noaa.gov/
https://libguides.library.noaa.gov/Section508/Library-Seminars
https://libguides.library.noaa.gov/Section508/CheckingAccessibility
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